Cook Computing

Installing del.icio.us on Firefox 1.5

January 30, 2006 Written by Charles Cook

I just tried to install the del.icio.us Firefox extension onto a Firefox 1.5 installation. A message bar appeared saying "To protect your computer, Firefox prevented this site (del.icio.us) from installing software on your computer". The Firefox extension page at del.icio.us instructs you to click on the accompanying Edit Options button and change the configuration to allow installation of extensions. But you can't do this in Firefox 1.5 because the option is no longer there.

The solution is to edit the Firefox configuration manually. Type "about:config" into the address bar and hit Enter. Find the xpinstall.enabled setting, which should be false if the above problem is occurring, and double click on it to set it to true. I think you then need to restart the browser.